Dwarves With A Passion
November 22, 2017, 10:22:53 am
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Welcome to Dwarves With A Passion!
 
  Home Help Search Staff List Login Register  

"Index was outside the bounds of the array"

Pages: [1]
  Print  
Author Topic: "Index was outside the bounds of the array"  (Read 449 times)
Thuellai
Escaped Lunatic
*
Posts: 3


View Profile
« on: October 27, 2008, 12:47:42 am »

EDIT:  Fixed this, got a new one:  "startIndex cannot be less than zero".  Why does Modbase hate me, friends?
« Last Edit: October 27, 2008, 12:55:24 am by Thuellai » Report Spam   Logged

Social Buttons

Skie
Bay Watcher
*
Posts: 5


View Profile
« Reply #1 on: October 28, 2008, 08:12:24 am »

I noticed that Modbase gives me an error if I try to install some of the very large mods, or more specifically, the very large components.
Martial Arts+ gives me always a crash if I try to install the Meta-megamagic items -component, for example. Most of the components from that mod work well, though, just not that one.

And after you've got an error once, you have to restart ModBase. Otherwise it keeps giving you errors when you try to install mods.
Report Spam   Logged
Sean Mirrsen
Bay Watcher
*
Posts: 8


View Profile
« Reply #2 on: October 28, 2008, 09:39:31 am »

Yeah, unfortunately the whole thing is pretty buggy. This being because I'm compiling it on the realitevely old .NET 2003 thing. I can't get Vista to accept the 3.5 framework (or the 3.0 one for that matter), and can't install the 2008 version. So, I get all kinds of glitches with people who, unlike me, update their OS. Tongue

The "Index outside of bounds" is because of the darn progress bar. No matter what I tried, it keeps accumulating integer convertion inaccuracies and after processing a very large module (like the Megamagic weapons ends up being - I'm not sure how large it is, but I'm suspecting up to a five-digit number of entries, depending on other installed mods as well) it tries to set the progressbar some 20 or 30 above its actual maximum. At least I think that's what causes it for most people, other variants can include mistreatment of the conditional tags, but that's a modder's problem.

The "Startindex cannot be less than zero" is something I haven't seen, but it's probably a case of the same mistreatment, because there might be little quirks in the syntax you don't know about.
Report Spam   Logged
Deon
Bay Watcher
*
Posts: 69


Dwarf Drunk


View Profile
« Reply #3 on: October 28, 2008, 11:47:05 am »

Hey, I'm glad to see that Sean is finally here!
Report Spam   Logged
Pages: [1]
  Print  
 
Jump to:  

Bookmark this site! | Upgrade This Forum
SMF For Free - Create your own Forum | Buy traffic for your forum/website

Powered by SMF | SMF © 2016, Simple Machines